Maintenance is now complete, and all systems are functioning normally. Orders, inventory, and shipments are currently queuing, and we expect regular operations to resume shortly.
Posted Sep 07, 2024 - 15:47 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 07, 2024 - 12:00 PDT
Scheduled
We are planning a significant upgrade to our systems starting at 12:00 PM PST on September 7th. During this maintenance window, we will not be transmitting or processing any orders or inventory. However, all orders will be queued and processed normally once the maintenance period is completed.
We appreciate your patience and understanding as we work to improve our systems. Please contact our support team if you have any questions or concerns.
Posted Sep 06, 2024 - 22:58 PDT
This scheduled maintenance affected: Channel, Core, and Connect.