Planned Maintenance
Incident Report for Acenda
Resolved
Maintenance complete
Posted Oct 04, 2020 - 07:26 PDT
Update
We are continuing to investigate this issue.
Posted Oct 04, 2020 - 07:25 PDT
Investigating
Planned maintenance. Some stores may experience brief downtime.
Posted Oct 04, 2020 - 07:18 PDT