Order Routing Issue

Incident Report for Acenda

Resolved

This incident has been resolved.
Posted Sep 08, 2024 - 13:03 PDT

Investigating

IT is currently investigating whether the order routing issue is still ongoing.
Posted Sep 08, 2024 - 11:37 PDT