New Store Creation: Javascript error

Incident Report for Acenda

Resolved

This incident has been resolved.
Posted Apr 16, 2020 - 18:23 PDT

Update

We are continuing to investigate this issue.
Posted Apr 16, 2020 - 18:23 PDT

Investigating

IT is investigating an error with new store creation. This is not impacting other services.
Posted Apr 16, 2020 - 17:31 PDT