Delayed Marketplace Order Processing

Incident Report for Acenda

Resolved

This incident has been resolved.
Posted Aug 27, 2026 - 08:37 PDT

Identified

Some clients may be experiencing delays in processing orders from marketplaces. Our team has identified the root cause and is actively working to resolve the issue. We will provide another update as soon as more information is available.
Posted Aug 27, 2026 - 08:25 PDT
This incident affected: Channel.