Upstream Cloudflare Outage

Incident Report for Acenda

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 04:17 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 04:17 PST

Identified

We are currently experiencing service disruptions due to an upstream outage at Cloudflare. This issue is not originating from Acenda, but it is affecting connectivity and platform availability.

Cloudflare is actively working to resolve the incident. You can track their progress and real-time status updates here: https://www.cloudflarestatus.com/

We will continue to monitor the situation and provide updates as more information becomes available.
Posted Nov 18, 2025 - 04:00 PST