Reports and Exports
Incident Report for Acenda
Resolved
This incident has been resolved.
Posted Feb 24, 2020 - 09:46 PST
Identified
The issue has been identified.
Posted Feb 24, 2020 - 09:40 PST
Investigating
Some stores reporting that the reporting tool and product exports from admin are sluggish.
Posted Feb 24, 2020 - 09:32 PST
This incident affected: Admin Tool.