Target+ Item Rejections Due to Tax Error

Incident Report for Acenda

Postmortem

TBD

Posted Nov 04, 2025 - 20:30 PST

Resolved

At approximately 4:00 PM PST, we identified an issue where items on Target+ were being rejected by Target’s system due to a Tax error. A fix was deployed at 6:45 PM PST, and affected items are expected to be restored shortly.
Posted Nov 03, 2025 - 19:26 PST
This incident affected: Channel, Core, and Connect.