Parent-Child Relationship Disruption

Incident Report for Acenda

Postmortem

As of 8:00 AM PST on August 15th, 2025, we observed that Target’s queue is still processing the backlog related to this incident. We expect this to clear with time.

Posted Aug 15, 2025 - 07:44 PDT

Resolved

Incident Summary:
On August 13th at approximately 5:00 PM PST, a bug was introduced that disrupted the parent-child product relationship in our system. While variant products remained available for purchase, they were no longer grouped with their respective parent products.

Resolution:
A patch was deployed on August 14th at approximately 3:00 PM PST. Within a few hours of deployment, the majority of parent-child relationships were successfully restored.

Preventive Measures:
To reduce the likelihood of similar issues in the future, we have implemented additional automated tests and real-time alerts to detect and address relationship integrity problems promptly.
Posted Aug 13, 2025 - 15:00 PDT