Admin Page Not Loading

Incident Report for Acenda

Resolved

Service has been restored. The root cause was a widespread Microsoft outage.
Posted Jul 23, 2026 - 11:32 PDT

Update

Posted Jul 23, 2026 - 09:41 PDT

Monitoring

This is part of a widespread Microsoft Azure service disruption affecting Acenda and many other organizations that rely on Microsoft’s cloud infrastructure. Additional information is available here:

https://www.fox13seattle.com/news/microsoft-outage-hits-teams-outlook
Posted Jul 23, 2026 - 09:39 PDT

Update

We continue to monitor and will provide updates accordingly.
Posted Jul 23, 2026 - 07:55 PDT

Identified

This issue is downstream from Acenda. We continue to monitor. All Acenda systems are normal.
Posted Jul 23, 2026 - 07:54 PDT

Investigating

We are currently investigating this issue.
Posted Jul 23, 2026 - 07:53 PDT
This incident affected: Channel, Core, and Connect.